MODX.Evo.Custom 1.2.1-d9.1.4 (02.05.2017)

Свеженький релиз в целом тут только исправление багов давних и не очень. Так же все краше становиться новая тема, заменили все иконки в дереве на FontAwesome работает шустрее + красивее отображается.

- MODxRE2 dropdownMenu , обновленна все иконки FA, убраны 2 фрейма с дерева и меню
- fix OnParseProperties event #1325
- fix Ditto + Cross references = not working
- fix Broken parser logic
- fix ddselectdocuments with jquery 3.1
- Managermanager work with tinymce4 (use richtext from modx settings)


Скачать можно тут:
modx.com.ua/download/
github.com/dmi3yy/modx.evo.custom/releases/tag/1.2.1-d9.1.4

Так же не забываем что есть чатик в телеграм: t.me/evolutioncms
И там же есть канал новостей t.me/evolutioncmsnews

48 комментариев

avatar
Блин, я обновляться не успеваю ))
avatar
Так +- раз в месяц жеж )
avatar
Кстати, сайтик на поддомене (DEV), обновиться не получается: нажатие на кнопку «Update» в Админке выдает такой УРЛ со страницей 404
http://поддомен.домен.ru/install/index.php?action=mode

И всё.
avatar
странное поведение шрифта в новом шаблоне, потестил в разных браузерах и пк:
1. странный жирный шрифт
2. при отключенном сглаживании в браузере — текст имеет тень и это его смазывает.

что-то в стилях не то)
avatar
Вот и я о том же. Может «у них там в маках» оно и нормально, но на винде этот жирный шрифт вызывает кровь из глаз. Если убрать bold становится значительно более читабельно.
avatar
Я ж вернул шрифт как был в целом на мак оно хорошо но если что могу поправить ибо должно быть у всех хорошо
avatar
Может там какое разрешение лучше или шрифты, но вот лично у меня на винде жирный 13-й шрифт смотрится слишком размыто, приходится править в теме на нежирный 14-й :)
avatar
Ну или как минимум просто убирать жирный шрифт
avatar
так в меню тоже смазывает текст, не знаю как у всех) у меня на винде невозможно смотреть нормально на сглаженные шрифты)
avatar
Если убрать еще и жирность в этой строке — вообще хорошо будет :)
avatar
попробуйте убрать в стилях темы
нас строке github.com/dmi3yy/modx.evo.custom/blob/master/manager/media/style/MODxRE2_DropdownMenu/style.css#L9

-webkit-font-smoothing: subpixel-antialiased !important; -webkit-backface-visibility: hidden; -moz-backface-visibility: hidden; -ms-backface-visibility: hidden;


отпишитесь пожалуйста, какой результат
avatar
Шрифт и правда режет глаз (его цвет), но это не из-за антиалиасинга, а из-за трансформаций, вот это надо убрать.

-webkit-backface-visibility: hidden; -moz-backface-visibility: hidden; -ms-backface-visibility: hidden;
avatar
в новой ветке с темой (пока на стадии тестирования)
github.com/64j/MODxRE2_jquery/tree/nojQuery
уже убрал большинство недочётов
avatar
Сама по себе тема классная, благодарю за работу.
avatar
результат позитивный, теперь не режет глаза и браузер нормально рендерит шрифт
avatar
обновленна все иконки FA, убраны 2 фрейма с дерева и меню
Это поломало плагин Manage TVs on Template, т.к. он теперь не может найти картинку на кнопке «сохранить» и дальше работать не хочет ибо cannot set property of null:)

тут и тут. Если закомментировать — то работает, но это ж не выход :)
Комментарий отредактирован 2017-05-03 11:27:18 пользователем webber
avatar
По картинкам в основном фрейме доберусь

А плагин нафиг? Если оно ж в ядре?

Или не пашет то что в ядре?
avatar
Я в ядре и не видел, но теперь попробовал — у меня перестало работать сортировка что плагином, что из ядра. Т.е. сама сортировка сохраняется, но выводит параметры не в соответствии с этой сортировкой
avatar
Отбой — не туда глянул, из ядра сортировка нормально работает, просто кнопка сильно неприметная :)
avatar
Извините, что не в тему…
В последних сборках не работает CResource+CustomTable https://github.com/webber12/customTables
Обновился на совместимость с поледними версиями MODx
При первом просмотре таблицы ресурсов в кеше записывается lock_ файл (document.parser -> evalPlugin();) и до сброса кеша плагин не запускается. В логе: Plugin parse error, Temporarily disabled 'CResourc и все. PHP ошибок и исключений нет. Куда копнуть не пойму
avatar
В тему;) а на 9.1.4 пробовали там как раз чинили параметры плагина
avatar
да, проверил в каждой с 1.2.1-d9.1.2 — по… 1.4
Результат одинаковый. При чем, после первого запуска с очистки кеша редакция документов возможна, запись в таблицы идет, и даже при вызове редактирования в стандартной форме. Но затем бесконечная системная надпись: «подождите, идет обработка»… пока кеш не обнулить.
С подменой в парсере evalPlugin на старую функцию из 7.1.6 симптомы те же, только плагин не блокируется
Комментарий отредактирован 2017-05-04 07:09:42 пользователем maximlit
avatar
Закомментировать вот это — в каждой из этих новых версий :)
avatar
Нужно это отключение плагинов сделать отключаемым, очень сильно раздражает.
avatar
Согласен, тем более нужный кусок весь находится в одном месте и легко поддается дополнительной проверке на «отключенность» :)
avatar
В след релизе сделаю
avatar
Так а можно подробней нафиг вообще лочить плагины? я чет не понял логику этого кода. Это Дессен что то там писал. Просто ни разу не ловил с этим багу:) можно в лет добавить доп параметр но не могу придумать зачем оно вообще надо?
avatar
Для этого надо сначала найти, где этот lock-файл создается, в парсере он только проверяется на наличие и удаляется :)
avatar
Можешь плз обрисовать проблему что бажит на git
я передам Dessen-у пусть поправит логика Лок это его работа.
avatar
Есть же уже issue 1301.
avatar
Кстати, не забудьте и сам customTables немного подновить под обновленные требования DocLister :) Остальное лучше обсуждать в соответствующей теме.
avatar
Все перечисленное было сделано изначально. Проблема вот в этом


после редактирования в форме вызванной из таблицы. Высвечивается до сброса кеша. Где-то есть проблема
Комментарий отредактирован 2017-05-04 10:00:12 пользователем maximlit
avatar
Ничего не понял. Вот эту проблему
При первом просмотре таблицы ресурсов в кеше записывается lock_ файл (document.parser -> evalPlugin();) и до сброса кеша плагин не запускается. В логе: Plugin parse error, Temporarily disabled 'CResourc и все. PHP ошибок и исключений нет. Куда копнуть не пойму

вот этот комментарий modx.im/blog/dmi3yy/5174.html#comment43786 решает точно.
avatar
Здесь отписал #comment43784 что сделано и какой результат. Проделано все — симптом — неисчезающая системная информация — остается

да, проверил в каждой с 1.2.1-d9.1.2 — по… 1.4
Результат одинаковый. При чем, после первого запуска с очистки кеша редакция документов возможна, запись в таблицы идет, и даже при вызове редактирования в стандартной форме. Но затем бесконечная системная надпись: «подождите, идет обработка»… пока кеш не обнулить.
С подменой в парсере evalPlugin на старую функцию из 7.1.6 симптомы те же, только плагин не блокируется
Комментарий отредактирован 2017-05-04 10:13:23 пользователем maximlit
avatar
На 9.1.2 все точно работало после комментирования куска с lock_ файлом. Ничего подменять не нужно было и никакой плагин не блокировался. Значит где-то в другом месте ошибка.
avatar
ок :) Еще буду проверять
avatar
del
Комментарий отредактирован 2017-05-04 06:04:34 пользователем maximlit
avatar
иконки в тини3 поехали)
prntscr.com/f3ldty
avatar
в Тини 3.5.11, всё нормально, на всех (двух) темах, что включены в последнюю сборку Modx
avatar
Кстати, еще насчет
обновленна все иконки FA
Из-за этой строки появились лишние иконки в Selector и multiTV. Пришлось заменить на
.sectionBody li:not(.Token):not(.TokenSearch):before { font-family: FontAwesome; content: '\f105'; display: block; font-weight: bold; font-size: 15px; color: #bdbdbd; position: absolute; margin-left: -13px; }
.sectionBody .multitv .list li:before{content:' ';}
Комментарий отредактирован 2017-05-04 13:53:38 пользователем webber
avatar
Комментарий отредактирован 2017-05-04 14:31:54 пользователем 64j
avatar
В Селекторе уже CSS поправили кстати, а вот в МультиТВ не пробовал пока.
avatar
Не хотелось бы после каждого обновления версии шерстить и обновлять и все используемые компоненты, изучая что там поправили, особенно если их функционал никак не связан с правками ядра :)
avatar
А я каждый раз прошу поставьте гляньте все ли ок
К примеру tiny3 evogallery альтернатива мультитв на манагерманагер я не использую поэтому и не тестирую даже эти компоненты
avatar
Ну так вот ставим-глядим-и пишем что не ок :) Так что без обид :)
avatar
Причем вполне конкретно, заметь пишем, чаще всего с причинами и с тем, куда смотреть. Не из разряда, как тут много бывает «не работает eFilter» — а у самого ошибка js в консоли и вообще ничего не работает. Или «не работает evoBabel» — а сам даже параметры общие и не собирался экспортировать/импортировать и т.п. :)
avatar
Поправил глюк с aliasListingFolder и учавствует урл таки принял решение которое рекомендовали.

Обновил tinyMCE

допилили еще админку

тестим отсюда github.com/dmi3yy/modx.evo.custom
завтра еще раз сам проверю и зарелизю но если кто потестит буду благодарен
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.