Новая версия TSVshop 5.4.2 (+ обновление до 5.4.3)

Приветствую всех!

Рад сообщить о выпуске обновления модуля для создания интернет-магазина на базе MODx Evo — TSVshop 5.4.2. В обновление вошли исправления некоторых найденных ошибок, в том числе проблемы с установкой на новых версиях MODx. Теперь модуль корректно устанавливается/обновляется и через инстяллятор (входит в пакет) и через Extras. Еще подкорректирована верстка модуля для работы в свежих версиях MODx 1.2.1+

Версия тестировалась на MODx 1.2.1 и 1.3.6. Все же есть потребность в том, чтобы как можно больше пользователей протестировали данную версию. Если если кто может/желает это сделать, пожалуйста, сообщайте о найденных ошибках или пожеланиях в комментарии.

Скачать свежую версию можно здесь: https://github.com/Serg28/tsvshop/releases/tag/v5.4.2

Оф.сайт модуля: tsvshop.xyz, новость на сайте: http://tsvshop.xyz/novosti/novaya-versiya-tsvshop-5.4.2.html

Обновление от 24.10.2017
Перезалил модуль, поэтому всем, кто скачал версию 5.4.2 до 24.10.2017 включительно, рекомендую заново скачать и обновить его.

Обновление от 27.10.2017
Чтобы не плодить темы, выкладываю здесь информацию о выпуске версии TSVshop 5.4.3. В нее вошли совсем небольшие исправления. Подробнее по ссылочке github.com/Serg28/tsvshop/releases/tag/5.4.3

5 комментариев

avatar
Ставлю dev версию Эво, поверх распаковываю файлы магазина, запускаю инсталятор — получаю ошибку на этапе «Проверка перед установкой».
Проверка возможности записи в папки /assets/cache и /assets/cache/rss: ОШИБКА!
Проверка возможности записи в папки /assets/images, /assets/files, /assets/flash, /assets/media, /assets/backup и /assets/.thumbs: ОШИБКА!

Насколько я понимаю, папки flash, media удалены.
Создаю папки, прохожу дальше, ошибка SQL
Создание таблиц базы данных: Внимание ошибка!
Программа установки EVO не смогла установить/изменить некоторые таблицы базы данных.
Следующая ошибка возникла во время установки

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'image', 'cart_icon', 'Картинка товара', 'Выводитс' at line 2 во время выполнения SQL запроса REPLACE INTO `evo_site_tmplvars` (`id`,	`type`, `name`, `caption`, `description`, `editor_type`, `category`, `locked`, `elements`, `rank`, `display`, `display_params`, `default_text`) VALUES (, 'image', 'cart_icon', 'Картинка товара', 'Выводится в каталоге, корзине и инфоблоке', 0, 38, 0, '', 0, '', '', ''), (, 'textareamini',	'tsvshop_param', 'Параметры товара',	'Дополнительные параметры товара, влияющие на цену', 0, 38, 0, '', 0, '', '', ''), (, 'text', 'articul', 'Артикул', 'Артикул товара', 0, 38, 0, '', 0, '', '', ''), (, 'number', 'price', 'Цена товара', 'Параметр обязателен', 0, 38, 0, '', 0, '', '', ''), (, 'number', 'inventory', 'Кол-во на складе', '', 0, 38, 0, '', 0, '', '', ''), (, 'richtext', 'demotext', 'Текст вверху', '', 0, 0, 0, '', 0, '', '', '').
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'image', 'cart_icon', 'Картинка товара', 'Выводитс' at line 2 во время выполнения SQL запроса .


Нажимаю закрыть в инсталяторе — открывает пустую страницу.
Пытаюсь залогиниться в адмнику — не получается. Приходится удалить куки, чтобы войти.

Windows, Openserver, php 5.6
Из Экстрас не ставил, там пока старая версия.
avatar
Спасибо за отчет. А у вас стоит mysql или mysqli?
avatar
Кстати, какая у Вас версия МОДх? Это обновление предназначено для работы на новых версиях МОДх, тестировалось начиная с 1.2.1 Если у Вас более раннние — ставьте 5.4.1

P.S. Вопрос отпадает, сразу не заметил про dev-версию. Сейчас попробую разобраться с ошибкой. До этого момента не встречал ее.
Комментарий отредактирован 2017-10-23 10:57:01 пользователем Serg28
avatar
Пока не смог воспроизвести ошибку — у меня такая же конфигурация. Но зато исправил ошибку при обновлении, когда затирались конфиги модуля. Чуть позже обновлю архив.

Еще у кого-то была похожая проблема при установке?
Комментарий отредактирован 2017-10-23 13:37:19 пользователем Serg28
avatar
Обновил файл для скачивания на гите, поэтому кто скачала версию 5.4.2 до 24.10.2017 включительно, рекомендую заново скачать и обновиться.
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.