Evolution CMS 1.4.7 (10.12.2018)

Багфикс релиз, направленный на исправление ошибок и повышение стабильности работы Evolution CMS


	 - [U] phpThumb 1.3.3 (AgelxNash) 
  	 - [U] ElementsInTree 1.5.10 (AgelxNash) 
  	 - [U] DocLister 2.4.1 (AgelxNash) 
  	 - [U] Formlister 1.8.1 (AgelxNash) 
  	 - [U] DocInfo  0.4.1 (AgelxNash) 
  	 - [U] FileSource 0.1 (Serg)
	 - [U] Updated extras url from extras.evolution-cms.com to extras.evo.im (dmi3yy) 
	 - [U] Updated Help Version Noticies 1.4.2 - 1.4.7 (Nicola) 
	 - [U] Updated Languages files: English, Italian, German, Spanish and Polish 
	 - [I] Colorpicker added to tinymce full theme (mnoskov) 
	 - [I] New Enable Mootools Setting Option (Load Mootools.js in manager for backward compatibility) (Nicola) 
	 - [I] #887 Elements in ElementsInTree plugin sorted by name (Nicola) 
	 - [F] Fix #874 Remove fullstop at end of new password (Serg) 
	 - [F] Fix #888 The FileSource 0.1 is dependent on the mootools (Serg) 
	 - [F] Fix #892 Duplicated element name issue (Serg) 
	 - [F] Fix #882 broken extras module link in RSS check (Nicola) 
	 - [F] Fix for php7 in ddmultiplefields.php 
	 - [R] Format code save_user_processor (Serg) 


Скачать можно тут: github.com/evolution-cms/evolution/releases/tag/1.4.7
  • avatar
  • +7
  • 2587

7 комментариев

avatar
После обновления не работает настройка TINYMCE в конфигурации. Добавляю кнопки —
forecolor backcolor fontsizeselect а в редакторе их не видно. Темы редактора меняются нормально.
Временно решил заменой строчки в файле theme.tinymce4.custom.inc.php
$this->set('toolbar1', $this->modxParams['custom_buttons1'], 'string', true );

$this->set('toolbar1', 'undo redo | cut copy paste | searchreplace | bold italic underline strikethrough | forecolor backcolor fontsizeselect | alignleft aligncenter alignright alignjustify | bullist numlist outdent indent blockquote | styleselect ', 'string', false );

Так внешний вид как мне надо
avatar
Где можно хоть краем глаза увидеть прототип Evolution 2?
avatar
avatar
Супер. Благодарю. Чувствую, будет божественно!
avatar
Перестало работать то ли TV-изображение, «прикрепляемое» к странице, то ли phpThumb. По крайней мере, такая конструкция
<img src="[[phpthumb? &input=`[+image+]` &options=`zc=1,q=100,w=500,h=250`]]">
работала до обновления сайта до Evolution CMS 1.4.7 (было 1.0.15), а после перестала. Сейчас показывает только noimage-***.png.

Основные настройки TV:

Тип ввода: Image
Визуальный компонент: [ничего].
avatar
Добрый день!

После переноса на новый хостинг, возникла проблема. Административная панель открывается без проблем, а вот сам сайт выдает следующую проблему…
ibb.co/m5jgcmR
ibb.co/q1TrFBY
Не подскажите в чем может быть проблема? Заранее благодарю.
avatar
Проблема в версии php у вас 5.4 а нужно 5.6 а лучше 7.1 или 7.2
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.