Evolution CMS 1.4.8 LTS (09.01.2019)

Evolution 1.4 LTS

Все новые возможности будут появляться только в ветке 2.0, а ветку 1.4 оставляем для старых проектов ну и для тех кто не хочет учить что то новое еще пару лет:)

Поддержка версии 1.4 будет такой:

— Исправление ошибок, доработка совместимости с веткой 2.x, и другие задачи направленные на стабильность до 02.02.2020
— Исправление критических проблем с безопасностью до 12.02.2021

Как обновить с более ранних версий:



Основные изменения в версии 1.4.8:
— [Updater — Изменена логика обновлений(1.4 to 1.5, 2.0 to 2.1) (Обновления между мажорными версиями будет реализована отдельным решение так как мажорные версии несут в себе изменения когда все же нужно внимание разработчика и сделать полностью все в автоматическом режиме не дает гарантии что все будет хорошо работать. (Dmi3yy)
— Phpthumb: нормально работает с svg файлами (Serg)
— Исправлен интересный баг когда вложенные друг в друга сниппеты выполнялись по 2 раза. Отсылка к коммиту #1200, там что то связанное с работой PHx было. (Dmi3yy)
— Исправление проблемы когда на главной в админке отображались кнопки которые запрешены (Dmi3yy)
— В теме Lightness исправленно отображение логотипа (Nicola)
— ElementsInTree сортировка по Алфавиту (Nicola)
— ManagerManager исправление пути к jQuery (Agel_Nash)
— Отображение ID Шаблона внутри документа (Dmi3yy)
— Больше совместимости с веткой 2.x (Agel_Nash)

Скачать тут:
github.com/evolution-cms/evolution/releases

Так же не забываем про телеграм чат:
t.me/evolutioncms

20 комментариев

avatar
После обновления не работает DLglossary. Выводится ошибка 404. До обновления все работало
  • gk71
  • 0
avatar
Проверьте что вы получали до обновления и после на 71 строке файла assets/snippets/DocLister/snippet.DLGlossary.php
avatar
Спасибо!
avatar
На одном сайте у меня выключен «Enable filters». После обновления с 1.4.7 перестали парситься некэшируемые вызовы сниппетов в чанках, просто преобразуется в кэшируемый [[...]]. Также, остался необработанным вызов сниппета, у которого в параметрах есть вложенный вызов сниппета.

Пример могу в личке показать, если надо будет.
avatar
Проверил специально вложенные снипеты и так и так все работает как нужно
github.com/evolution-cms/evolution/issues/977
avatar
Сейчас в личку для примера ссылку дам.
avatar
Спасибо Дмитрию, разобрались.
О причинах он написал на гитхабе.
avatar
В довесок смотрим вот тут последний комент я наглядно показываю почему не стоит использовать вложеность снипетов больше 2-х:
github.com/evolution-cms/evolution/issues/977

avatar
Обнаружил глюк, не знаю, связан ли с этой версией. Но ранье такого не наблюдал.
В настройках системы выставлены вот такие опции:

И при загрузке jpef-файла через KCFinder, размер которого не большой (порядка 600Кб), но при этом разрешение у файла — 4000х3000, получаю вот такую ошибку:


Проверял и параметры хостинга (всякие там upload_file_size и иже с ними), и с версиями PHP эксперементировал — не помогает.
Помогло только выставление опции, ранее показанной на скриншоте, в «изменение размеров на стороне клиента». Конечно, я вышел сейчас из положения с помощью этой опции, но по идее, раз по умолчанию выставлен вариант преобразования картинки на сервере, то проблема всплывет еще ни один раз.
avatar
Здравствуйте!
Система 1.4.8
Кто-нибудь сталкивался, что при установке сертификата SSL (Cloudfare), перестает корректно работать админка сайта(не выводятся ресурсы страниц, в конфигурацию невозможно попасть).
Комментарий отредактирован 2019-02-13 08:53:40 пользователем tmih
  • tmih
  • 0
avatar
Может кому пригодится решение.
Полечилось переустановкой на версию 1.4.7 и правильным редиректом.
avatar
Думаю вопрос толко в правильном редиректе ибо в 1.4.8 по части редиректов ничего не делалось по сравнению с 1.4.7 )
avatar
Дмитрий, спасибо! Вы правы — вчера вечером обновили до 1.4.8 и все заработало отлично (и админка и базовый УРЛ). Хотя «танцы» долго велись, но никакие редиректы не помогали.
Получается, что при переносе с хостинга на хостинг лучше повторно сверху обновить ту же версию системы.
avatar
Тут вопрос в том что такие сервисы как Cloudfare все кешируют и оно из за этого не сразу работает как надо
avatar
Здравствуйте! Ошибка 504 после входа в админку. Скачал evolution-1.4.8.zip, залил архив на хостинг reg.ru, распаковал архив. Выполнил установку, установка прошла успешно, но после входа в админку получаю ошибку 504. Написал в техподдержку хостинга и получил ответ:
[pid 11281] lstat("/home/./public_html/prokol/manager/./config.inc.php", 0x7ffde04d0480)
[pid 11281] lstat("/home/./public_html/prokol/manager/../vendor/autoload.php", 0x7ffde04d1710) = -1 ENOENT (No such file or directory)
[pid 11281] lstat("/home/./public_html/prokol/manager/./messageCount.inc.php", 0x7ffde04d0480) = -1 ENOENT (No such file or directory)
[pid 11281] access("/home/./public_html/prokol/assets/cache/installProc.inc.php", F_OK) = -1 ENOENT (No such file or directory)
Попробуйте выполнить чистую переустановку: evo.im
Если ошибка сохранится, рекомендуем обратиться к разработчикам данной CMS.

Указанные файлы на сервере присутствуют. Прошу помощи.
avatar
ИМХО, где-то папки местами попутаны. Что говорит установка через 1-click installer? github.com/evolution-cms/installer
avatar
Через installer установка не проходит. После нажатия «install» пол-минуты страница грузится, потом ошибка 500 Internal Server Error. В папках на сервере пусто, install.php удалился и других файлов не создалось.
avatar
На php 5.4 совсем не будет работать или только некоторые сниппеты, плагины?
На гите в требованиях теперь пхп от 7.1.3 подавай 0_О
Стоит сейчас 1.4.6, не работает только DLMenu из стандартного…
avatar
2.0 7.1.3+

А на 1.4.8 так же как и на 1.4.6
avatar
блин, точно! не там смотрю)
спасибо
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.