Переадресация на https Evolution CMS на хостинге masterhost

Вроде бы стандартная задача, на данном хостинге не получается нормально поставить переадресацию.

Mixed Content и отваливается вся верстка сайта.

Для восстановления верстки изменил
RewriteRule ^(manager|assets|js|css|img)/.*$ — [L]
на
RewriteRule ^(manager|assets|js)/.*$ — [L]

Для некоторых файлов, по прежнему mixed content, замок не зеленый. Когда поставил переадресацию через ПУ, отвалилась админка, в админке файл по адресу assets загружен по http, а должен быть через https (идет ссылка на редактор, который лежит в assets)

Переключатель протокола в админке установил, кто-нибудь стаkrbdfkcz с решением?

Находил несколько тем, но ни одно решение не сработало.

Сначала настраивал то что «пришло» от клиента, потом вставил htacess из свежего дистрибутива. Проблемы не решило.

8 комментариев

avatar
У хостера написано же, в htaccess:
RewriteEngine On
RewriteCond %{HTTP:PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R]

Плюс посмотри что у тебя в base href пишется, и на всякий случай задай не через глобальную переменную [(base_href)] а ручками: htts://site.com
Комментарий отредактирован 2019-07-05 18:36:14 пользователем liberpro
avatar
Спасибо за ответ.
Да, так и прописал, но только в одном случае, файл, почему-то, грузится через http
avatar
так может у него абсолютная ссылка?)
avatar
нет)), ./../image.jpg
avatar
а base href какой стоит? тут уже не серверная часть скорее всего, если вопрос только в одном файле)
avatar
<base href="https://www.site.ru/">
, прописано вручную, вместо [(base_href)]
Комментарий отредактирован 2019-07-06 03:52:20 пользователем dv555
avatar
Посмотрите, вот мои недавние пляски с бубном вокруг мастерхоста — может быть, поможет:
modx.im/blog/news/5839.html#comment51922
avatar
И вот еще мой фрагмент .htaccess для мастерхоста:


<IfModule security2_module>
SecRuleRemoveById 942100
</IfModule>

php_flag apc.cache_by_default Off
#....... ........
RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.mysite\.ru$ [NC]
RewriteRule ^(.*)$ https://www.mysite.su/$1 [L,R=301]


#Options +FollowSymlinks
RewriteEngine On
RewriteCond %{HTTP:PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteEngine On
RewriteBase /

#...... ........
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.