Проблемы с SimpleGallery

Всем здравствуйте.

Появилась проблема с SimpleGallery — на вкладке галереи загружаются не все превью. Не при загрузке фотографий, а просто, когда открываешь страницу для редактирования. При чем проблема возникает только если фотографий много, превью для пары десятков подгружаются без проблем. При перезагрузке страницы или если несколько раз открыть/закрыть её, то подгружаются все превью.


Браузер выдает :
Failed to load resource: the server responded with a status of 503 () ajax.php:1

В техподдержке хостинга мне написали, что
На данном сайте превышается лимит на максимальное количество подключений пользователей:
Oct 31 12:38:26 vh8 apache_error: [Thu Oct 31 12:38:26.837573 2019] [mpm_itk:warn] [pid 16489] MaxClientsVhost reached for fdm.agency:86, refusing client.


Но до недавнего времени всё было в порядке и никакие работы на сайте не проводились. Подскажите, от чего может возникнуть такая проблема?
Evolution 1.4.9, SimpleGallery 1.2.4

5 комментариев

avatar
А какой хостинг? У меня на таймвеб с недавнего времени в менеджере изображений такое происходит. Суть в том, что миниатюры запрашиваются через прослойку в виде php-скрипта, и из-за этого каждое соединение подпадает под действие настройки MaxClientsVhost. В случае, если бы делался прямой запрос к статичному изображению, такой проблемы бы не было.
avatar
Это именно таймвеб. До этого сайт лежал на beget, всё нормально было.
avatar
Вариантов решения несколько — переехать на другой хостинг, переехать на другой тариф, либо ждать изменений в simplegallery. Лучше всего переехать обратно на beget, хороший хостинг.
avatar
Спасибо большое за ответ)
Переезд на другой хостинг пока не вариант, придется менять тариф.
avatar
Проблему подтверждаю, на nic.ru иногда блочат соединения
Почему нельзя напрямую запрашивать превьюхи непонятно
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.